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Welcome 

Welcome to the CubeViewer 4 Tutorial.  This tutorial is designed to give you a 
basic understanding of the operations of the CubeViewer 4 program by taking 
you through the most common functions within the program. 
 
The tutorial is organized around the SAW Juice Company demonstration data that 
can be downloaded from the Cabot website (see Installing the SAW Juice 
Company Data section below).   
 
If you prefer, you can run the tutorial using any SAW Sales Analysis cubes, on 
the understanding that the structure of the data may not be identical to that of 
the tutorial and that you may have to improvise on some of the steps.   
 
Specifically, the names and number of levels in the cube dimensions may not be 
the same and you may need to drill down an additional level to get to the 
transaction level.  
 
If you are unsure about doing this, please follow the instructions below to 
download the SAW Juice Company demonstration data. 
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Installing the SAW Juice Company Data 

 
The SAW Juice Company demonstration data can be downloaded from the Download Demo page of the www.cabotinc.ca website. 
 

 
 
 
 
Select the SAW Juice Company Demo Folders Installation (3-n-n)  
 

 
 
 
Click Run on the file download window. 
 

 
 
 
Click Run on the security warning window. 
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Click OK on the SAW Juice Demo Files Installation window. 
 

 
 
 
Click Unzip on the Winzip Extractor window. 
 

 
 
 
Click OK on the Unzip Successful window. 
 

 
 
 

See also 
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Tutorial 
The turorial is designed as a single session tutorial - some of the steps rely on steps completed in prior sessions.  Please start on the first step - Getting 
Started - and work your way linearally through the rest of the sessions. 
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Getting Started 

Get started by opening the CubeViewer 4 program attached to a SAW Sales Analysis cube source by choosing one of the following options: 
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Opening the SAW Juice Company Data 

Open the CubeViewer program by double-clicking on the Sales Demo (.cb4) settings file in the OpenFiles folder of your Sales Demo.  

 
 
 
Set the Time Period to the last complete Fiscal Year for the data - for the SAW Juice Company demo use Year 2010 periods 1 to 12. 
 
 

 
 
 
Save the Settings file as "Tutorial"  (File -> Save Settings File As .. menu option). 
 
 

 
 
 

 
 
 
 
If at any time you accidentally overwrite the Tutorial file you can open the Sales Demo file and repeat the above steps to get it back to the correct state for 
the tutorial. 
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Using a different SAW Sales Analysis Source 

To use a different source open the CubeViewer 4 program attached to a SAW Sales Analysis cube and then: 
 
Set the the Time Period to the last complete year of data. 
 

 
 
 
Close all but the first tab. 
 

 
 
 
Open the Settings Screen. 
 

 
 
 
And set the settings as close to the following settings as you can. 
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Save the Settings file as "Tutorial"  (File -> Save Settings File As .. menu option). 
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You may want to make a copy of the Tutorial file just in case you accidentally overwrite it during the tutorial. 
 

See also 

Opening the SAW Juice Company Data 

 
 

  
10 . Tutorial

 
  

  
CubeViewer 4 Tutorial



Home > Tutorial > Understanding the Main CubeViewer 4 Screen 

Understanding the Main CubeViewer 4 Screen 

The main CubeViewer 4 screen is split into three main sections: the Display Grid and two Charts.  You control what and how things are displayed through the main 
Menu and Toolbar options. 
 

 
 
 
Or by using the right click context menus on the grid and charts. 
 

 
 
 
You can click on on any of the column headings to sort the gird first in ascending order and then in descending order. 
 

 
 
 
The left chart shows summary information and the right chart shows detail.  You have the ability to change the size of the sections. 
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Or to hide the charts entirely. 
 

 
 
 
Ensure that you have the charts displaying before moving on to the next section. 
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Navigating Down through the Data 

This section shows you how to navigate down through the levels of the cube from the summary overview to the detail transaction level. 

Position on one of the large Product Class lines in the Display grid and click on the Drill toolbar button to open a new tab displaying the Products from the 
selected Product Class. 
 

 

Double-click on one of the Products in the Product Class to open a new tab with the transactions from the selected Product. 
 

   

Click on the Close Tab toolbar button to close the tab of the transactions. 
 

 
 
 
Right click on the Products Tab and select the Close Tab menu option to close the Products screen. 
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Click on the Settings toolbar button to open the Display Grid Settings screen. 
 

 
 
 
 
Select the Area Desc dimension as the Row Dimension and click the OK button to change the grid to a display of the Areas. 
 

 
 
 
Repeat the exercise of drilling through the levels to the transaction level with the new dimension and repeat closing the opened tabs. 
 
To finish this section reset the Row Dimension to the Product Class Desc and leave the CubeViewer 4 program open with just one open tab. 
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Navigating Sideways Across the Data 

This section shows you how to move sideways across the cube data opening new tabs for some of the mainy dimensions stored in the cubes. 
 
Click on the New Tab toolbar button to open the Grid Display Settings dialog window. 
 

 

 
Select Area Desc in the Row Dimension and press OK. 
 

 
 
 
Right click in the new grid and select the New Tab menu option to open the Grid Display Settings dialog window. 
 

 
 
 
Select Branch Desc in the Row Dimension and press OK. 
 

 
  

  
Tutorial . 15

 
 

  
CubeViewer 4 Tutorial



 
 
 
Select the Naviagation -> Open New Tab main menu option to open the Grid Display Settings dialog window. 
  

 
 
 
Select Salesperson Name in the Row Dimension and press OK. 
 

 
 
 
You should now have four tabs open in the CubeViewer 4 program and can freely move between each tab. 
 
Leave the program open with the four tabs open to finish this section. 
 

See also 
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Changing the Chart Formats 

This section shows you how to change the format of the charts in each tab.  If the charts are not currently displaying in the main CubeViewer screen, click 
on the Charts -> Hide Charts main menu option to uncheck it and show the charts. 
 

 
 
 
Click on the first tab and then select the Chart -> Chart 2 -> Settings main menu option. 
 

 
 
 
Click on the Chart Format 3D option button and click OK to change the Chart 2 in the first tab to a 3D format.  
 

 
 
 
Click on the second tab and then right click on the second chart and select the Settings menu option. 
 

 
 
 
Click on the Line chart type and click OK. 
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Click on the third tab and select the Settings menu option and then select the Bar chart type and the 3D chart format option button and click OK. 
 

 
 
 
You should now have four tabs open with different chart styles in each tab. 
 
Leave the program open with the four tabs open to finish this section. 
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Exporting the Data and Charts 

This section shows you how to easily export and share the data and charts with other applications.  However, please note that the Export to Excel options 
are only available on computers that have Microsoft Excel installed. 
 
Click on the first tab and select the Export -> Export Grid as Excel -> Data Only main menu option. 
 

 
 
 
Select an appropriate name and location for the export. 
 
Click on the File -> Switch To Excel File main menu option to open the exported spreadsheet. 
 

 

 
 
 
Close the Excel spreadsheet and then click on the Export -> Export As Excel Workbook -> Include Chart toolbar button option. 
 

 
 
 
Click on the File -> Switch To Excel File main menu option to open the exported workbook, which will include a spreadsheet for each tab with the chart 
included in each spreadsheet. 
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Close the Excel workbook and click on the top left cell of the first tab to select the entire grid (all cells should turn blue).  Right click on the grid and select 
the Copy to Clipboard menu option. 
 

 
 
 
Open Word from Start -> Programs menu.  Change the page layout to Landscape and then Edit -> Paste the clipboard into the document.  The grid will be 
copied in as a Word table. 
 
Leave the Word document open and return to the CubeViewer program.  Select a portion of the grid data and repeat the Copy to Clipboard option. 
 
 

 
 
 
Return to the Word document, tab down below the imported grid and then paste in the section of the grid. 
 
Leave the program open with the four tabs open to finish this section. 
 

See also 
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Saving and Opening Settings Files 

This section shows you have to save and re-open the various views that you create. 
 
With the four tabs open from the previous section, select the File -> Save Settings File As .. main menu option. 
 

 
 
 
Enter the name as "Tutorial View" and then close down the CubeViewer program without saving. 

 
 
 
In the Open Files folder you should now see the new Tutorial View settings file (.cb4).  Double click on this file to open the CubeViewer 4 program with all 
the tabs configured as per the previous sections. 
 

 
 
Once the program has finished loading, select the File -> Open Settings File main menu option and select the Tutorial settings file to open. 
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You should be back to a single active tab as per the start of the Tutorial.  Leave the program open with the single tab active. 
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Applying Filters 

This section shows you how to apply filters to view and analyze sub-sets of the cube data. 
 
Make a not of a couple of the large Product Classes in the current Grid.  Select the Filters toolbar button. 
 

 
 
 
In the Filters screen, double click on the Product Class Desc name to expand the dimension tree and then check one of the Product Classes that you made a note of. 
 

 
 
Close the Filters screen to display the single Product Class.  Open the Settings window and change the Row Dimension to Area Desc and click okay to display the sales of the 
selected Product Class by Area. 
 

 
 
 
Right click on the grid and open a new tab.  Change the Row Dimension to Customer Class to display the sales of the selected Product Class by Customer Class. 
 

 
 
 
Click on the Filters toolbar button, expand the Product Class Desc tree and then check the second Product Class that you made a note of. 
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Close the Filters screen to display the sales of either of the Product Classes by Customer Class. 
 

 
 
 
Double click on one of the Customer Class lines to open a new tab listing all the Customers in that Customer Class that have purchased either of the selected Product Classes. 
 

 
 
 
Close the CubeViewer 4 program without saving the settings to finish this section. 
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Changing Measures, Calculations and Timeframe 

This section shows you have to look at different values, use different calculations and view the cube data over different timeframes. 
 
 
Open the CubeViewer 4 program by double clicking on the Tutorial settings file.  Click on the Settings toolbar button and then click on the Measures and 
Calculations tab. 

 
 
 
Change the Second Measure to Sales Qty, the Calculation to 1/2 and the Calculation Heading to AvPrice and click OK to show an average price calculation in 
the grid. 
 

 
 
 
Click on the Timeframe toolbar button and change the From Period to 10 to display sales for the last 3 periods only. 
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Close the CubeViewer 4 program without saving the settings to finish this section. 
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Changing the Display Style 

This sections shows you the seven different display styles supported by the CubeViewer 4 program. 
 
Open the CubeViewer 4 program by double clicking on the Tutorial settings file.  Click on the New Tab toolbar button and change the Display Style to Annual Growth. 
 

 
 
AnnualGrowth: 
 

 
 
Create new tabs with each of the other Display Styles.  When choosing the CrossJoin display style se the Column Dimension to Area Desc. 
 
CrossJoin: 
 

 
 
ListValues: 
 

 
 
PeriodComparative: 
 

 
 
 
PeriodProfile: 
 

 
 
 
PeriodYearToDate: 
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Close the CubeViewer 4 program without saving the settings to finish this section. 
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Cube Structure and Help 

This section demonstrates how to view the structure of the current cube and how to access the online help. 
 
Open the CubeViewer 4 program by double clicking on the Tutorial settings file. 
 
Click on the Structure toolbar button to show all the dimensions and measures in the current cube and expand the tree on a dimension to show the levels 
for that dimension. 
 
 

 
 
 
Close the Structure window and click on the Help toolbar button (or Help -> Online Help main menu option) to display the online help. 
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Close the CubeViewer 4 program without saving the settings to finish this section and the tutorial. 
 
Visit the CubeViewer 4 Online Help for more information. 

 
 

See also 

Getting Started 
Understanding the Main CubeViewer 4 Screen 
Navigating Down through the Data 
Navigating Sideways Across the Data 
Changing the Chart Formats 
Exporting the Data and Charts 
Saving and Opening Settings Files 
Applying Filters 
Changing Measures, Calculations and Timeframe 
Changing the Display Style 

 
 

  
32 . Tutorial

 
  

  
CubeViewer 4 Tutorial

http://www.cabotinc.ca/Help/CubeViewer4/Static/Default.htm


Index 
 



 
 
 
 
 
 

CubeViewer 4 Tutorial 

 
  

  
PDF Back Cover . 33

 
 

  
CubeViewer 4 Tutorial


	PDF Cover Page
	PDF Blank Page 1
	PDF Title Page
	PDF Blank Page 2
	Welcome
	Installing the SAW Juice Company Data

	Tutorial
	Getting Started
	Opening the SAW Juice Company Data
	Using a different SAW Sales Analysis Source

	Understanding the Main CubeViewer 4 Screen
	Navigating Down through the Data
	Navigating Sideways Across the Data
	Changing the Chart Formats
	Exporting the Data and Charts
	Saving and Opening Settings Files
	Applying Filters
	Changing Measures, Calculations and Timeframe
	Changing the Display Style
	Cube Structure and Help

	PDF Back Cover

